Как сравнить два столбца в Excel с помощью ВПР

Сравнение двух столбцов в Excel не должно быть сложной задачей, и для выполнения этой работы мы предлагаем использовать функцию ВПР. Видите ли, не всегда; столбцы, которые вы хотите сравнить, находятся в одной книге или электронной таблице; следовательно, традиционный способ сравнения вещей увеличил бы рабочую нагрузку. В этом руководстве объясняется, как использовать формулу ВПР для сравнения максимум двух столбцов в предложении, чтобы получить общие значения или найти отсутствующие данные.

Как сравнить два столбца в Excel с помощью ВПР

Как сравнить столбцы в Microsoft Excel

Как уже говорилось, мы можем использовать функцию Excel VLOOKUP для поиска и сопоставления разных данных или поиска различий в двух столбцах.

  1. Сравните столбцы (найдите и сопоставьте разные данные)
  2. Найдите различия, сравнив два столбца

1) Сравните столбцы (найдите и сопоставьте разные данные)

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

ВПР доступна и недоступна

Во многих случаях у вас, вероятно, будет два столбца в электронной таблице Excel с данными, и ваша задача — выяснить, существует ли точка данных в одной из ячеек. Подобная ситуация не требует использования функции ЕСЛИ или знака равенства, а требует ВПР.

Объясним, как выполнить работу в рекордно короткие сроки и без проблем.

Запустите приложение Microsoft Excel.

После этого откройте книгу или таблицу, содержащую данные.

Если вы еще не добавили данные, откройте новую таблицу и заполните ее соответствующей информацией.

Теперь, если у вас есть набор данных, в котором и столбец A, и столбец B заполнены именами, вы можете отобразить одинаковые имена из обоих столбцов в столбце C. Например, если Миртл находится и в A, и в B, функция ВПР может поместите это имя в C.

Все, что вам нужно сделать, это ввести следующую команду:

=ЕСЛИОШИБКА(ВПР(B2,$A$2:$A$10,1,0),”Нет совпадений”)

Имейте в виду, что мы используем No Match, если совпадение не найдено. В этом случае вместо пробела или #N/A появятся слова No Match.

2) Найдите различия, сравнив два столбца

Как сравнить два столбца в Excel с помощью ВПР

Еще одно назначение функции ВПР — поиск различий в двух столбцах. Это простая задача, поэтому давайте поговорим о том, как это сделать.

Мы подозреваем, что у вас уже есть Excel и рабочая книга со всеми данными.

Итак, мы подозреваем, что у вас есть данные в столбцах A и B, например, имена.

Если вам нужно узнать имена, которые находятся в столбце B, но отсутствуют в столбце A, то используйте следующую команду:

=ЕСЛИ(ЕОШИБКА(ВПР(B2,$A$2:$A$10,1,0)),”Недоступно”,”Доступно”)

Приведенная выше формула будет сравнивать имя в столбце B со всеми именами в столбце A. Если будет найдено точное совпадение, формула обеспечит возврат имени, а если нет, вместо него появится #N/A. По этой причине мы решили включить функции ЕСЛИ и ЕОШИБКА, завернутые в ВПР.

Таким образом, когда имя отсутствует, эта формула будет показывать «Недоступно», а если оно присутствует, она вернет «Доступно».

ЧИТАЙТЕ: исправьте ошибку Excel, обнаруженную нечитаемым содержимым

Может ли функция ВПР вернуть 2 столбца?

Если вы хотите использовать функцию ВПР одновременно для нескольких столбцов, просто создайте одну формулу массива или используйте вспомогательные столбцы, если вы не заинтересованы в использовании формул массива.

Что такое пример формулы ВПР?

Используйте формулу ВПР в Excel, чтобы найти значения в таблице. Например, вы можете использовать =ВПР(A2,A10:C20,2,ИСТИНА) или =ВПР(“Фонтана”,B2:E7,2,ЛОЖЬ) в качестве альтернативы. Все зависит от столбцов и того, чего вы хотите достичь.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *